[BioC] problems with tcltk library

Byron Ellis bellis@hsph.harvard.edu
Fri, 21 Jun 2002 00:09:56 -0400 (EDT)

This is USUALLY set by ActiveTcl...However, if you have Ruby installed
this will be all screwed up (I found this out the hard way). You can set
the environment variable youself in under Win2K/XP by going to the System
control panel and selecting the Advanced tab. There should be a button
labeled 'Environment Variables' where you can either set or modify
TCL_LIBRARY to the appropriate path.

Byron Ellis (bellis@hsph.harvard.edu)
"Oook" - The Librarian

Please finger bellis@hsph.harvard.edu for PGP keys

On Fri, 21 Jun 2002, Jeff Gentry wrote:

> > I just downloaded and installed the ActiveTcl  But, it's still not working.  When I was trying to include library(tcltk), I got the same error message.
> > > library(tcltk)
> > Error in firstlib(which.lib.loc, package) : 
> >         TCL_LIBRARY is not set
> > Error in library(tcltk) : .First.lib failed
> Just a guess, but something that might help - it looks like it wants an
> environment variable TCL_LIBRARY.  I have no idea how to set environment
> variables in Windows, but you might want to try setting one named
> TCL_LIBRARY and pointing it to where your TCL is installed.
> -J
> _______________________________________________
> Bioconductor mailing list
> Bioconductor@stat.math.ethz.ch
> http://www.stat.math.ethz.ch/mailman/listinfo/bioconductor