[BioC] RWin crashes on normalization with >21 Cel files

Eric emblal@uky.edu
Wed, 18 Sep 2002 18:17:35 -0400

Hi (pardon me if this is a resend- I was not sure if the first attempt made 
it through),

RWin (1.5.1) crashes when I try to normalize more than 21 cel files. 
ReadAffy() loads 29 cel files (that's the most I've tried) with no 
problems, and I can make box plots and histograms etc., but any procedure 
that involves normalization (default "quantiles") crashes me out of R 
(Windows says: "R has generated errors and is being shut down by Windows"). 
I reduced the number of cel files to 20 and the normalization worked fine. 
It also worked with odd numbers of cel files (I tried 21, 19, 15, and 9) 
but 21 seems to be some sort of capacity, no number of cel files between 21 
and 30 successfully normalized. I've also tried various cel files in the 
infamous "22" slot to see if there may have been a problem with a 
particular cel file, but so far 7 different files all give the same result.

I've hit the same limit with both an AMD Thunderbird and a PIII 1GHz 
processor- both with 512MB RAM running the same O/S (Win2K SP2).

Other potentially useful info
affy package d/l'd yesterday from CRAN
Affymetrix rat arrays (RG-U34A)

I'd appreciate any help with this- or hearing if anyone else has had 
similar problems or knows of a workaround. I'm a complete novice with R, 
and other than setting my command line memory and typing "ReadAffy" and 
"normalize" (my two word vocabulary) I fear I am rather hopeless.


Eric Blalock, PhD
Dept Pharmacology, UKMC
859 323-8033