[BioC] limma reading genpix files

Gordon K Smyth smyth at wehi.EDU.AU
Thu Apr 8 23:56:06 CEST 2004

> hello all limma exprts,
> I have started using limma to analyse some spotted microarray data  but
> have run into problems trying to read the data files in.
>  From the limma guide, having specified the "files" ,  then using the
> command:
>   RG<-read.maimages(files, source="genepix")
> I get:
> Read 7863scan3.gpr
> Error in read.table(fullname, skip = skip, header = TRUE, sep = sep,
> as.is = TRUE,  :
> 	more columns than column names

Something is wrong with your second data file.  Have you looked at it to

> I have 4 .gpr files that were generated from genepix version 3 with
> 7863scan3 being the first
> I also tried specifying columns as mentioned in the limma guide:
> RG<-read.maimages(files, columns=list(Rf="F635 Median", Gf="F532
> Median", Rb="B635 Median", Gb ="532 Median"))
> and got
> Error in "[.data.frame"(obj, , columns$Gb) :
> 	undefined columns selected.

The error message seems to me to be not impossible to interpret.  It tells
you that you've tried to specify a column that doesn't exist and that the
offending column is Gb.  If you look at your own code you'll see an
obvious typo.


> I have no idea how to interpret these error messages and have to say
> that my forays into BioConductor have been a frequent exercise in
> frustration because of constant unintelligible error messages. Could
> some one please help me in solving these issues.
> I'm running R 1.8.0 on MacOS X and recently updated limma (1.3?)
> thanks
> Bryce
> 	[[alternative HTML version deleted]]

More information about the Bioconductor mailing list