[BioC] recipe for installing and using Bioconductor with Mac OS X 10.3 and R GUI 1.9

Simon Kidd kidd at mail.rockefeller.edu
Wed Apr 14 00:16:56 CEST 2004

At 5.15pm -0400 13/4/04, Marc Salit wrote:
>Dear Colleagues --
>I've been trying unsuccessfully to use Bioconductor (mostly the affy 
>package) on a Mac with OS X 10.3.3, running R with a GUI, either 
>1.8.1 or 1.9.0 beta. I've tried to install Bioconductor with 
>getBioC.R, which doesn't work all the way, and also tried to use a 
>shell command to install downloaded packages, a la R CMD INSTALL 
>/path/to/pkg_version.tar.gz , which also doesn't work all the way 
>(stops when it can't find a 'make' command in SHLIB.
>Suggestions? Caveats? Will this work? Shall I give up and 'switch' 
>back to a PC???

Ive installed R1.9 beta from :


and then used its gui  to install the Bioconductor Affy (and a few 
others) packages.  Other than some problems with tcltk and limmaGUI 
and what I think is a different problem with simpleaffy things have 
worked (as much as I can tell). This is with OSX10.3.3,  and  the X11 
and the developer tools which came with it.

More information about the Bioconductor mailing list