[BioC] recipe for installing and using Bioconductor with Mac OS X 10.3 and R GUI 1.9

Anthony Bosco anthonyb at ichr.uwa.edu.au
Wed Apr 14 04:07:28 CEST 2004

To install individual packages on Mac OSX use Terminal (under 

In terminal type in something like:

cd /Applications/StartR.app/RAqua.app/Contents/MacOS/
./R CMD INSTALL /Users/anthonyb/Desktop/ellipse_0.2-12.tgz



>X-Original-To: anthonyb at ichr.uwa.edu.au
>Delivered-To: anthonyb at ichr.uwa.edu.au
>X-Sender: Message-Id: <p06100502bca2156b493e@[]>
>Date: Tue, 13 Apr 2004 18:16:56 -0400
>To: Marc Salit <salit at nist.gov>, bioconductor at stat.math.ethz.ch
>From: Simon Kidd <kidd at mail.rockefeller.edu>
>Subject: Re: [BioC] recipe for installing and using Bioconductor with Mac
>	OS X	10.3 and R GUI 1.9
>X-Virus-Scanned: by amavisd-new
>X-BeenThere: bioconductor at stat.math.ethz.ch
>X-Mailman-Version: 2.1.4
>List-Id: The Bioconductor Project Mailing List 
>	<mailto:bioconductor-request at stat.math.ethz.ch?subject=unsubscribe>
>List-Archive: <https://www.stat.math.ethz.ch/pipermail/bioconductor>
>List-Post: <mailto:bioconductor at stat.math.ethz.ch>
>List-Help: <mailto:bioconductor-request at stat.math.ethz.ch?subject=help>
>List-Subscribe: <https://www.stat.math.ethz.ch/mailman/listinfo/bioconductor>,
>	<mailto:bioconductor-request at stat.math.ethz.ch?subject=subscribe>
>Sender: bioconductor-bounces at stat.math.ethz.ch
>X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on
>	poohbear.ichr.uwa.edu.au
>X-Spam-Status: No, hits=-2.9 required=7.0 tests=AWL,BAYES_00,SUBJ_HAS_SPACES
>	autolearn=no version=2.63
>At 5.15pm -0400 13/4/04, Marc Salit wrote:
>>Dear Colleagues --
>>I've been trying unsuccessfully to use Bioconductor (mostly the 
>>affy package) on a Mac with OS X 10.3.3, running R with a GUI, 
>>either 1.8.1 or 1.9.0 beta. I've tried to install Bioconductor with 
>>getBioC.R, which doesn't work all the way, and also tried to use a 
>>shell command to install downloaded packages, a la R CMD INSTALL 
>>/path/to/pkg_version.tar.gz , which also doesn't work all the way 
>>(stops when it can't find a 'make' command in SHLIB.
>>Suggestions? Caveats? Will this work? Shall I give up and 'switch' 
>>back to a PC???
>Ive installed R1.9 beta from :
>and then used its gui  to install the Bioconductor Affy (and a few 
>others) packages.  Other than some problems with tcltk and limmaGUI 
>and what I think is a different problem with simpleaffy things have 
>worked (as much as I can tell). This is with OSX10.3.3,  and  the 
>X11 and the developer tools which came with it.
>Bioconductor mailing list
>Bioconductor at stat.math.ethz.ch


Anthony Bosco - PhD Student

Institute for Child Health Research
(Company Limited by Guarantee ACN 009 278 755)
Subiaco, Western Australia, 6008

Ph 61 8 9489  , Fax 61 8 9489 7700
email anthonyb at ichr.uwa.edu.au

More information about the Bioconductor mailing list