[BioC] Bug in affy library

Francesco Falciano f.falciano at cineca.it
Wed Apr 28 14:52:00 CEST 2004

I tried to install Bioconductor 1.3 in R 1.9.0. for linux suse 8.0.

I was able to install some libraries, but for some of them the installation fails.

One of these is affy: when the installation file tries to install the manual the message obtained is:



normalize.constant                text    html    latex
  normalize.contrast                text    html    latex   example
  normalize.invariantset            text    html    latex

ERROR: command (e.g. \url) inside \link
ERROR: building help failed for package 'affy'
** Removing '/cineca/prod/Bioinf/R/R-1.9.0/library/affy'


I found the problem.

There is a sintax error in the code generating the help for the function loess.normalize.  

I solved the problem:

Unpacking the affy_1.3.28.tar.gz

editing the file normalize.loess.Rd in man subdirectory of affy:

on line 38 change the line:

\link {loess.normalize} for a complete description


\code{\link {loess.normalize}} for a complete description

zip the file again and launch the function R CMD INSTALL again.

Hope this is helpful!

Dr Francesco Falciano
(High Performance Systems)
via Magnanelli, 6/3
40033 Casalecchio di Reno (BO)-ITALY
tel: +39-051-6171724
fax: +39-051-6132198
e-mail: f.falciano at cineca.it

	[[alternative HTML version deleted]]

More information about the Bioconductor mailing list