[BioC] affy package in MacOSX

Tiago R Magalhaes tiago17 at socrates.Berkeley.EDU
Wed Jul 14 13:22:24 CEST 2004


I have been trying to load the affy package not very sucessfully 
(details of what I did bellow)
I am using a G4 Mac running the OSX Panther and I have the R version: 
1.9.0. I don't know if the affy package simply won't run on the 
panther OSX - I have been sucessful in installing UNIX packages in 
the Mac R, but those didn't have any C code or things more complex 
and I randomly know that at least one function of the affy package 
(rma) has some C code.

any help would be greatly appreciated! Thank you very much for 
helping running this wonderful system and for making all these 
fantastic tools available.

what I did:
packages menu and then under bioconductor I tried to download the 
affy bundle that results in:

local({source(paste(getOption('BIOC'), 'getBioC.R',sep='/'), 
local=TRUE); getBioC('affy', destdir=.libPaths()[1])})

it doesn't work I get an error saying that it wasn't found in any 
respository (I copied the message bellow)

I also tried to download the package to my computer and tried to 
install it, but unfortunately it doesn't install either:

finally, when I installed BioConductor I had gotten some error 
messages as well: I reproduce some of them

error installing the Affy package from the Menu Package => 
BioConductor => AffyBundle:
[1] "Attempting to download affy from 
http://www.bioconductor.org/repository/release1.4/package/Source" [1] 
"Download complete." [1] "Installing affy" Note: Package affy not 
found in any known repository. Note: Package affydata not found in 
any known repository. [1] "Attempting to download affyPLM from 
http://www.bioconductor.org/repository/release1.4/package/Source" [1] 
"Download complete." [1] "Installing affyPLM" [1] "Attempting to 
download matchprobes from 
http://www.bioconductor.org/repository/release1.4/package/Source" [1] 
"Download complete." [1] "Installing matchprobes" Note: You did not 
specify a download type.  Using a default value of: Source This will 
be fine for almost all users

error when trying to install the affy package from the local disk:
>  install.from.file()	npackage installation failed

(one of the errors I got when trying to install BioConductor):
previously I installed BioConductor and I also got may of those 
warnings (I copy here one of them)
[1] "Installing XML" Note: Package XML not found in any known 
repository. Note: You did not specify a download type.  Using a 
default value of: Source This will be fine for almost all users
	[[alternative HTML version deleted]]

More information about the Bioconductor mailing list