[BioC] rbind in annaffy problem

James W. MacDonald jmacdon at med.umich.edu
Tue Dec 13 17:04:27 CET 2005

Kimpel, Mark William wrote:
> I am having a problem with rbind in annaffy. I have a very simple
> annaffy table that, for the sake of illustration, I have tried to
> duplicate by row binding to itself (this is a simplification of a more
> complex problem).
> Here is my code:
> affytable.temp<-subset.affytable.on.GO.func(affytable=table,
> GO.TERM=common.go.hyper$"GO ID"[i], GO.Desc="GO Term")

Looks like the correct method is not being dispatched on your aafTable. 
I get the same result unless I force things with

bound <- annaffy:::rbind.aafTable(affytable.temp, affytable.temp)

I think this is a problem due to the fact that rbind.aafTable is an S3 
method and an aafTable is an S4 object.

Did you email Colin Smith directly?



James W. MacDonald
Affymetrix and cDNA Microarray Core
University of Michigan Cancer Center
1500 E. Medical Center Drive
7410 CCGC
Ann Arbor MI 48109

More information about the Bioconductor mailing list