[BioC] Installing Bioconductor under Linux

fhong at salk.edu fhong at salk.edu
Tue Jun 7 02:59:55 CEST 2005

Hi list;

I am sorry if my question is too basic, I don't have much background in

I am trying to install Bioconductor under linux. By following the manual,
I first installed R 2.1.0 from R-2.1.0.tar.gz downloaded from R website

tar xvfz R-2.1.0.tar.gz

Then I have successfully run

I met errors and wouldn't go through when I tried
make check  (or make check FORCE=FORCE or make check-devel)

But it looks like R is installed. After I copied shell-script 'R' to
'usr/local/bin/R', typing 'R' on the command line invokes the R of current
version. ( there is an old version R installed, I just simple replace the
old R at 'usr/local/bin' by the new one)

But when I tried to install Bioconductor, I met the problem
> source("http://www.bioconductor.org/getBioC.R")
X connection to localhost:10.0 broken (explicit kill or server shutdown).

This didn't happen when I used the old version R. Any suggestion is
greatly appreciated!!

Thanks in advance.

Fangxin Hong  Ph.D.
Plant Biology Laboratory
The Salk Institute
10010 N. Torrey Pines Rd.
La Jolla, CA 92037
E-mail: fhong at salk.edu
(Phone): 858-453-4100 ext 1105

More information about the Bioconductor mailing list