[BioC] read.GenePix not opening connection

michael watson (IAH-C) michael.watson at bbsrc.ac.uk
Wed Jun 29 21:37:43 CEST 2005

Please post all your code, including the contents of whatever file you read into SamsfishTargets.

The error you are getting is because R cannot find the files you are telling it to open.  99.999999999% of the time this is user error :-)


-----Original Message-----
From:	bioconductor-bounces at stat.math.ethz.ch on behalf of Amy Mikhail
Sent:	Wed 29/06/2005 8:34 PM
To:	bioconductor at stat.math.ethz.ch
Subject:	[BioC] read.GenePix not opening connection


I am new to microarray analysis and have been trying to use marray (in R
2.1.0) to read in data from GenePix (.gpr) files, but it hasn't worked...

There are 6 .gpr files (e.g. samcellINF8a.gpr as below), the sample
description .txt file and a .gal file in my directory (folder containing
files is called Samsfish).  I've been trying to copy the example in the
vignette entittled "Quick Start Guide for marray".  It worked fine up
until the following line of code:

> data <- read.GenePix(targets=SamsfishTargets)

...which gives me this error message:

Error in file(con, "r") : unable to open connection
In addition: Warning message:
cannot open file './samcellINF8a.gpr'

(or variations on a theme)

Do you know what this means?

What can I do about it?

Many thanks,

Amy Mikhail
Research student
University of Aberdeen
Zoology Building
Tillydrone Avenue
Aberdeen AB24 2TZ
Email: a.mikhail at abdn.ac.uk
Phone: 00-44-1224-272880 (lab)

Bioconductor mailing list
Bioconductor at stat.math.ethz.ch

More information about the Bioconductor mailing list