[BioC] problems using simpleaffy

Georg Otto georg.otto at tuebingen.mpg.de
Tue Mar 29 20:11:22 CEST 2005

Dear Crispin,

thanks a lot for your answer!

> I suspect this is an issue with compiling/running on a Mac - which is 
> something I'm afraid I have no experience of doing...

This seems indeed to be the case. Running the R implementation of mas5

  x.mas5 <- call.exprs(x, "mas5-R")

gives me decent scale factors.

> The other issue - with the subscript out of bounds error is due to the 
> GAPDH probeset id being incorrect in the data files with the 
> package... I've fixed that, and I'll post a patched version in the 
> next few days.

When and where will this patch be available? I downloaded and installed 
simpleaffy_2.10-1 from the 25th of march from the developmental 
packages site, but I still get the same error:

qc<-qc(x, x.mas5R)
Getting probe level data...
Computing p-values
Doing PMA Calls
Error in FUN(X[[4]], ...) : subscript out of bounds



>> -----Original Message-----
>> From: bioconductor-bounces at stat.math.ethz.ch
>> [mailto:bioconductor-bounces at stat.math.ethz.ch] On Behalf Of Georg >
>> Otto
>> Sent: 22 March 2005 21:43
>> To: bioconductor at stat.math.ethz.ch
>> Subject: [BioC] problems using simpleaffy
>> Hi bioconductors,
>> I have a problem trying to reproduce the user´s guide of simpleaffy
>> with my own data. I do it like this:
>>> x<-read.affy("covdesc")
>>> x.mas5<-call.exprs(x,"mas5")
>> Background correcting
>> Retrieving data from AffyBatch...done.
>> Computing expression calls...
>> ..........done.
>> scaling to a TGT of 100 ...Scale factor for: 1.CEL
>> 1.27818905696529e-247 Scale factor for: 2.CEL 8.30729457715284e-252
>> Scale factor for: 3.CEL 1.27818905696529e-247 Scale factor for: 4.CEL
>> 1.27818905696529e-247 Scale factor for: 5.CEL 2.37641150479280e-156
>> Scale factor for: 6.CEL 2.37641150479280e-156 Scale factor for: 7.CEL
>> 1.27818905696529e-247 Scale factor for: 8.CEL 1.27818905696529e-247
>> Scale factor for: 9.CEL 2.37641150479280e-156 Scale factor for: 10.CEL
>> 2.37641150479280e-156  > qc.data<-qc(x, x.mas5) Getting probe level
>> data...
>> Computing p-values
>> Doing PMA Calls
>> Error in FUN(X[[4]], ...) : subscript out of bounds
>> First of all , the Scale factors look pretty odd. Secondly, I have no
>> clue, what the error message means. I would appreciate any hint.
>> I am running simpleaffy 2.10 with R 2.0.1 on  powerpc-apple-darwin6.8
>> Best,
>> Georg
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> --------------------------------------------------------

More information about the Bioconductor mailing list