[BioC] Problems using text to subset array information from anexpression set

Alvord, Greg (DMS) [Contr] gwa at css.ncifcrf.gov
Tue Apr 4 21:35:20 CEST 2006

	Hi Jeff - 

	I'm a rookie myself with Bioconductor and R (been at it a couple
of weeks).  It appears that

> Data <- ReadAffy()
> alldata <- rma(Data) 

alldata is now simply a an AffyBatch object.  It is not a matrix or data
frame.  If you create an object

> alldata.exprs <- exprs(alldata)

you create a matrix, but still not a data frame.  You still may have
problems naming the rows and columns explicitly.  Create a data frame,

> alldata.exprs.df <- data.frame(alldata.exprs)

creates a data frame.  And then you can easily extract something like

> alldata.exprs.df["1007_s_at',] 


> alldata.exprs.df[,"AA100.CEL")

I think.  Hope this helps.  As a newcomer I'm trying to extract objects
from Bioconductor operations in objects like matrices and data frames
that I'm more familiar with. 

HTH, Greg  

W. Gregory Alvord, Ph.D.
Director, Statistical Consulting Services
Computer and Statistical Services
National Cancer Institute at Frederick
Fort Detrick at 7th Street
Post Office Box B
Miller Drive, Building 362, Room 33
Frederick, MD  21702-1201
Phone:  301.846.5101
Fax:  301.846.6196
E-mail:  gwa at css.ncifcrf.gov

-----Original Message-----
From: bioconductor-bounces at stat.math.ethz.ch
[mailto:bioconductor-bounces at stat.math.ethz.ch] On Behalf Of Jeff Lande
Sent: Tuesday, April 04, 2006 2:16 PM
To: bioconductor at stat.math.ethz.ch
Subject: [BioC] Problems using text to subset array information from
anexpression set

I have an odd problem that I cannot seem to figure out.

I have a set of CEL files in a directory, which I read using the
command.  Then I run the rma command to preprocess.  

> Data <- ReadAffy()
> alldata <- rma(Data)

I've done this many times before without problems.  However, when I try
use text instead of numbers for subscripting, I get an error.  

For example, I am able to access data from the first row and column
numeric subscripts

> alldata[1,1]
Expression Set (exprSet) with
        1 genes
        1 samples
                 phenoData object with 1 variables and 1 cases
                sample: arbitrary numbering

but using text for either subscript, I get an error.

> alldata["1007_s_at",]
Error in alldata["1007_s_at", ] : no 'dimnames' attribute for array
> alldata[,"AA100.CEL"]
Error in alldata[, "AA100.CEL"] : no 'dimnames' attribute for array

I actually went through what I think was the same process last week (and
many times previously) and had no problems, so I'm stumped.

Here is my session information:

> sessionInfo()
R version 2.1.0, 2005-04-18, ia64-unknown-linux-gnu

attached base packages:
[1] "tools"     "methods"   "stats"     "graphics"  "grDevices" "utils"
[7] "datasets"  "base"

other attached packages:
hgu133acdf       affy reposTools    Biobase
   "1.4.3"    "1.6.7"   "1.5.19"   "1.5.12"

I must be missing something obvious, but I just can't figure out what is
going wrong.  Does anyone have insight into this problem?

Jeff Lande
Post-Doctoral Associate
University of Minnesota

Bioconductor mailing list
Bioconductor at stat.math.ethz.ch
Search the archives:

More information about the Bioconductor mailing list