[BioC] Building BioC packages from source on MacOSX (R-2.3.0)

Benilton Carvalho bcarvalh at jhsph.edu
Mon Apr 10 20:10:11 CEST 2006

Hi Seth,

I removed the binary R that I had and the /Library/Frameworks/R.framework 
directory. I also rebuilt R from the source and I get the same error. I'll 
keep trying and if I have any success, I'll let you know.

thanks for your help,

On Mon, 10 Apr 2006, Seth Falcon wrote:

> Benilton Carvalho <bcarvalh at jhsph.edu> writes:
>> i do have a .Rprofile, which sets the pager and the editor. Even upon
>> its removal i get the same error.
>> is there a way i can make sure R is (not) picking up an old config
>> file? i was positive i deleted everything before (re)trying, but i
>> might have missed something.
> The error message you reported has this in it:
>    ** arch - Frameworks
>    /Library/Frameworks/R.framework/Resources/share/make/shlib.mk:3:
>    /Library/Frameworks/R.framework/Resources/etc/Frameworks/Makeconf: No such file
>    or directory
>    make: *** No rule to make target
> So I would try nuking /Library/Frameworks/R.framework
> But I'm still quite puzzled.  For example, I have such a directory
> from a binary install of R, but it does not interfere with my from
> source R build.
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

More information about the Bioconductor mailing list