[BioC] Question about turning strings into variable names in R

J.delasHeras at ed.ac.uk J.delasHeras at ed.ac.uk
Thu Mar 1 15:36:00 CET 2007


Thanks Sean and Steen, for alternative solutions. Great!

I have used a list before for similar purposes, but I now wanted a  
more "direct" approach. 'get' and 'eval(parse())' is what I was  
looking for now.

Thanks!

Jose

Quoting Sean Davis <sdavis2 at mail.nih.gov>:

> On Thursday 01 March 2007 07:22, J.delasHeras at ed.ac.uk wrote:
>> Hi,
>>
>> I have a situation where I have a vector of variable names. If I call
>> any of them, I get a text string (the name is surrounded by ""). How
>> can I use that as a variable name again?
>>
>> For instance, I have objects a, b and c, and a vector v<-c("a","b","c").
>> If I want to return the contents of a, I can't do just v[1], because
>> that only shows "a"...
>> Is there a simple way to indicate that "a" should be taken as the name
>> of an object, and not as a string? If so, I haven't found it...
>
> http://cran.r-project.org/doc/FAQ/R-FAQ.html#How-can-I-turn-a-string-into-a-variable_003f
>
> However, you probably don't need (or want) to do this.  Use a list instead.
>
> v <- list()
> v[['a']] <- a
> v[['b']] <- b
> ...
>
> Sean
>
>



-- 
Dr. Jose I. de las Heras                      Email: J.delasHeras at ed.ac.uk
The Wellcome Trust Centre for Cell Biology    Phone: +44 (0)131 6513374
Institute for Cell & Molecular Biology        Fax:   +44 (0)131 6507360
Swann Building, Mayfield Road
University of Edinburgh
Edinburgh EH9 3JR
UK



More information about the Bioconductor mailing list