[BioC] Loading problem with Rlibstree and microRNA packages on Mac OS X 10.4

Luo Weijun luo_weijun at yahoo.com
Fri Nov 28 18:44:02 CET 2008

Dear all,
I called microRNA package when I tried rtracklayer package on a Mac OS X 10.4 machine. Errors produced when loading the depended package Rlibstree (see below).
I tried installed Rlibstree alone from binaries or source, both failed. Error messages (see below). suggested that R_newStringSet and R_stringSetAdd functions (in stree.c file) had problem when passing argument 1 of 'lst_string_new'. This seems to be consistent with the loading error message, but I am not sure what does it mean. Could anybody help or give any hints. Thanks a lot!

#Loading error
Loading required package: Rlibstree
Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared library '/Library/Frameworks/R.framework/Resources/library/Rlibstree/libs/ppc/Rlibstree.so':
  dlopen(/Library/Frameworks/R.framework/Resources/library/Rlibstree/libs/ppc/Rlibstree.so, 6): Symbol not found: _lst_alg_longest_common_substring
  Referenced from: /Library/Frameworks/R.framework/Resources/library/Rlibstree/libs/ppc/Rlibstree.so
  Expected in: dynamic lookup

Error: package 'Rlibstree' could not be loaded
> sessionInfo()
R version 2.8.0 (2008-10-20) 


attached base packages:
[1] tools     stats     graphics  grDevices utils     datasets  methods  
[8] base     

other attached packages:
[1] matchprobes_1.14.0 affy_1.20.0        Biobase_2.2.1     

loaded via a namespace (and not attached):
[1] affyio_1.10.1        preprocessCore_1.4.0

Installing error (from source)
gcc -arch ppc -std=gnu99 -I/Library/Frameworks/R.framework/Resources/include -I/Library/Frameworks/R.framework/Resources/include/ppc -I../local/include/ -I/usr/local/include    -fPIC  -g -O2 -c prefix.c -o prefix.o
gcc -arch ppc -std=gnu99 -I/Library/Frameworks/R.framework/Resources/include -I/Library/Frameworks/R.framework/Resources/include/ppc -I../local/include/ -I/usr/local/include    -fPIC  -g -O2 -c stree.c -o stree.o
stree.c: In function 'R_newStringSet':
stree.c:100: warning: passing argument 1 of 'lst_string_new' discards qualifiers from pointer target type
stree.c: In function 'R_stringSetAdd':
stree.c:316: warning: passing argument 1 of 'lst_string_new' discards qualifiers from pointer target type
gcc -arch ppc -std=gnu99 -dynamiclib -Wl,-headerpad_max_install_names -mmacosx-version-min=10.4 -undefined dynamic_lookup -single_module -multiply_defined suppress -L/usr/local/lib -o Rlibstree.so prefix.o stree.o -L../local/lib -lstree  -F/Library/Frameworks/R.framework/.. -framework R -Wl,-framework -Wl,CoreFoundation
/usr/bin/libtool: for architecture cputype (16777223) cpusubtype (3) object: /usr/local/lib/libgcc_s.10.4.dylib malformed object (unknown load command 4)
make: *** [Rlibstree.so] Error 1
chmod: /Library/Frameworks/R.framework/Versions/2.8/Resources/library/Rlibstree/libs/ppc/*: No such file or directory
ERROR: compilation failed for package 'Rlibstree'
** Removing '/Library/Frameworks/R.framework/Versions/2.8/Resources/library/Rlibstree'
** Restoring previous '/Library/Frameworks/R.framework/Versions/2.8/Resources/library/Rlibstree'

More information about the Bioconductor mailing list