[BioC] EBImage installation

Bernd Jagla bernd.jagla at pasteur.fr
Wed Apr 29 16:48:31 CEST 2009


Thanks I was able to compile from sources now and everythings works fine.
I just get the following message:

> library(EBImage)
Le chargement a ncessit le package : abind
Xlib:  extension "RANDR" missing on display "/tmp/launch-1igmhB/:0".

By the way, do you know how to change from French to English?



-----Original Message-----
From: Gregoire Pau [mailto:gregoire.pau at embl.de] 
Sent: Wednesday, April 29, 2009 4:37 PM
To: Bernd Jagla
Cc: bioconductor at stat.math.ethz.ch
Subject: Re: [BioC] EBImage installation

Hi Bernd,

If you have the libraries ImageMagick (6.5.1-0) and gtk2 (2.16.1) 
installed with MacPort then the following shell commands,
- 'display --version'
- 'gtk-demo'
should work (testing ImageMagick and GTK+).

Just download the *source* package of EBImage here:
and install it using 'R CMD INSTALL EBImage_3.0.0.tar.gz'.
That's it and EBImage should work fine.

I suspect you did something wrong because MacPort installs libraries in 
/opt/local/lib (and not in /usr/lib) so maybe you were trying to install 
the Mac binary package of EBImage which seems to use 
/usr/local/lib/libMagick.10.dylib. But the name of the ImageMagick 
library has changed since... (it is now called libMagickCore, explaining 
why you can't find it on your system).

If it doesn't work, could you please give me all your details with 
sessioInfo() and the output of the following commands:
- 'otool -L src/EBImage.so'
- 'Magick-config --libs'
- 'pkg-config gtk+-2.0 --libs'

Best regards,

Gregoire Pau
EMBL Research Officer

Bernd Jagla wrote:
> Hi,
> I am trying to install EBImage (now on a MacPro)
> I have ImageMagick 6.5.1-0 installed (using MacPort) and gtk2 (2.16.1,
> using MacPort).
> When I install EBImage everything is OK. But when executing / loading the
> library it complains that libraries are not available. I then look for
> libraries and symbolically link them to the directory where they are
> "supposed" to be. This worked reasonably well (I actually think it should
> working out of the box). Now I am stuck with ImageMagick that should be in
> /usr/local/lib/libMagick.10.dylib.
> I couldn't find this file on my computer but I guess it should be there
> because the description of the MacPort package says that the libraries are
> installed as well.
> And I also tried to recompile from source: Here I don't get passed the
> ./configure script. There are no error message and no Makefile is created.
> don't know what is going wrong here. 
> Thanks for your comments and help. Sorry for my ignorance.
> Best,
> Bernd
> 	[[alternative HTML version deleted]]
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives:

More information about the Bioconductor mailing list