[BioC] Error in package goseq

Joydeep Mitra joy.mitra at yahoo.com
Tue Aug 17 20:52:04 CEST 2010


I am a grad student at Institute of Bioinformatics, University of Georgia, USA. 
I have been trying to use the bioconductor package goseq for go-term/pathway 
enrichment of my expression data.
Since my organism of interest isn't included in the goseq database, I am 
manually entering the data for gene lengths and categories following the 
directions in the vignette provided with the package. I have tried representing 
the gene-category mappings in both data frame and list formats as specified.
While the 'nullp' function worked fine for my data, when I run goseq() with the 
following command, I get an error message:

> eco1.gs<-goseq(DEgenes=eco1.de,pwf=eco1.pwf,gene2cat=ids.go.list)
Using manually entered categories.
Error in summary(map)[, 1] : incorrect number of dimensions

Here's my session info:

> sessionInfo()
R version 2.11.1 (2010-05-31) 

[1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] goseq_1.0.3            geneLenDataBase_0.99.4 BiasedUrn_1.03        

loaded via a namespace (and not attached):
 [1] AnnotationDbi_1.10.2  Biobase_2.8.0         biomaRt_2.4.0         
Biostrings_2.16.9     BSgenome_1.16.5       DBI_0.2-5            
 [7] GenomicFeatures_1.0.6 GenomicRanges_1.0.6   grid_2.11.1           
IRanges_1.6.8         lattice_0.18-8        Matrix_0.999375-39   
[13] mgcv_1.6-2            nlme_3.1-96           RCurl_1.4-2           
RSQLite_0.9-1         rtracklayer_1.8.1     tools_2.11.1         
[19] XML_3.1-0    

Has anyone else faced this problem in goseq? Any help is appreciated.


More information about the Bioconductor mailing list