[BioC] Rsamtools hangs reading SOLiD bam files

Asta Laiho asta.laiho at btk.fi
Tue Oct 12 09:27:24 CEST 2010


I'm trying to work with *.bam and *.bai files produced using Bioscope (SOLiD related software package, v.1.2.1). I tried two examples in the Rsamtools manual (the one on top of the page 2 for querying the reads in the given range, and the one on the bottom of the page 4 for calculating coverages for chunks of the file). I tried with files of different sizes (35Mb, 1.8Gb) but the code in both examples just kept running without any error messages and without producing results in any reasonable time. I even left it running over night but it still hadn't finished. My computer has Mac OS X 10.6.4 with 8Gb memory. The session info is attached below. Are there any known issues with Rsamtools and bam/bai files originating from SOLiD Bioscope software?

Many thanks for all advice in advance,

R version 2.11.1 (2010-05-31) 

[1] C/UTF-8/C/C/C/C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] Rsamtools_1.0.8     Biostrings_2.16.9   GenomicRanges_1.0.7
[4] IRanges_1.6.11     

loaded via a namespace (and not attached):
[1] Biobase_2.8.0

More information about the Bioconductor mailing list