[BioC] Library installation: odd error

Steve Lianoglou mailinglist.honeypot at gmail.com
Tue Jul 12 22:06:27 CEST 2011

Hi Michael,

On Tue, Jul 12, 2011 at 3:47 PM, Michael Bauer <mjbauer at eecs.tufts.edu> wrote:
> I am a system administrator at a site with several R users.  In response to
> a previous set of questions, we were encouraged to have individual users set
> up R library directories in their home directories and use the R environment
> variables to direct R to put auto-installed libraries there.
> However, we've run across one consistent problem: the library that prompted
> this whole string will not install on Linux.  (It installs just fine in R on
> Windows.)  When presented with a writable library directory to install into,
> it the installation invariably fails with the error:
> Error in ret[i, ] <- c(pkgs[i], lib, desc) :
>  number of items to replace is not a multiple of replacement length

I'll cut here.

This has happened to me recently. Any time I tried to install
*anything* I would get this error.

So, first question: is it only when you try to install a particular
package that this happens, or are all package-installs now hosed?

I'm going to assume that all package installs are not working.

This error was happening to me because there is a package that is
*already* installed in the system which is "corrupt". I had installed
a library that "hand crafted" its own installation, and I guess the
meta-data that R requires a package to have has changed over time
causing this custom-installed-package to trip things up.

The details of my situation and how I fixed it are here:

The details of your problem are likely different -- but maybe this
will help you find the offending package (if one exists)?

Is there some package that was installed in a non-traditional manner?

If you compare the output of `installed.packages()`[*] between your
linux and windows install, you can find which packages are installed
on the linux machine and not the windows machine that might be causing
these problems.



[*] you probably want to use `installed.packages()[,1]` since the
object returned from the function call is a matrix.

Steve Lianoglou
Graduate Student: Computational Systems Biology
 | Memorial Sloan-Kettering Cancer Center
 | Weill Medical College of Cornell University
Contact Info: http://cbio.mskcc.org/~lianos/contact

More information about the Bioconductor mailing list