[BioC] import .cel file in Ubuntu system

Steve Lianoglou mailinglist.honeypot at gmail.com
Sat Jul 30 20:23:34 CEST 2011

Hello 郭小波,

On Wed, Jul 27, 2011 at 1:11 AM, 郭小波 <mc03gxb at 126.com> wrote:
> Hello,
>       I want to import a .cel file into R.  Under the Windows platform, i used the command "read.celfile" in the package "affyio" and successfully imported the data. However, when i turned to used R in Ubuntu and repeated the same steps, there was an error:
>  "read.celfile("/home/bmi01/P1/1.CEL") :
>  Is /home/bmi01/P1/1.CEL really a CEL file? tried reading as text, gzipped text, binary and gzipped binary
>  Calls: read.celfile -> .Call"
>  What is the problem?

It looks as if that file doesn't "look like" a cel file.

You mentioned that read.celfile previously worked in windows, though.
Did it work for *this* particular cel file that you are now trying to
import under linux, or were you saying that it has just worked before
on some other cel files you might have been using?


Steve Lianoglou
Graduate Student: Computational Systems Biology
 | Memorial Sloan-Kettering Cancer Center
 | Weill Medical College of Cornell University
Contact Info: http://cbio.mskcc.org/~lianos/contact

More information about the Bioconductor mailing list