[BioC] Help with installing genefilter -- "installed directory not writable"

Dan Tenenbaum dtenenba at fhcrc.org
Mon Oct 22 08:03:42 CEST 2012

On Sun, Oct 21, 2012 at 1:47 PM, Kee Pang SOH <soh.kee.pang at gmail.com> wrote:
> Hi.
> I am a student and I am currently learning about microarray analysis.  I
> tried to install genefilter package on my Ubuntu OS, but run into the
> following problem.
> Input:
>> source("http://bioconductor.org/biocLite.R")
>> biocLite("genefilter")
> Error message:
> The downloaded source packages are in
>     ‘/tmp/RtmpUU7GsP/downloaded_packages’
> Warning message:
> installed directory not writable, cannot update packages 'boot', 'cluster',
> 'mgcv', 'spatial'

This is just a warning message. It means that these packages were
previously installed (probably by an administrator) in a directory you
don't have permission to write to. Seems like genefilter installed


> I have tried to google for this error message, but I wasn't able to find
> anything useful. Would appreciate if someone could advise me on how to rectify
> this issue.
> Thank you.
> Yours faithfully
> Kee Pang
> _________________________________
> CONFIDENTIAL NOTE: The information contained in this e-mail and any
> accompanying document may contain information that is privileged,
> confidential or otherwise protected from disclosure. If you are not the
> intended recipient of this message, or if this message has been addressed
> to you in error, kindly inform the sender and delete the mail. Thank you.
>         [[alternative HTML version deleted]]
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at r-project.org
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

More information about the Bioconductor mailing list