[BioC] Problem installing goseq and RCurl

Dave Tang davetingpongtang at gmail.com
Wed Oct 31 09:47:14 CET 2012

On Tue, 30 Oct 2012 22:06:21 +0900, Dan Tenenbaum <dtenenba at fhcrc.org>  

> On Tue, Oct 30, 2012 at 6:03 AM, Dave Tang <davetingpongtang at gmail.com>  
> wrote:
>> Hi Dan,
>> On Tue, 30 Oct 2012 21:43:35 +0900, Dan Tenenbaum <dtenenba at fhcrc.org>
>> wrote:
>>> What Linux distribution are you running?
>>> If ubuntu, try:
>>> sudo apt-get install libcurl4-openssl-dev
>>> (this is from http://www.omegahat.org/RCurl/FAQ.html)
>> I'm working on a shared server where I don't have admin privileges and  
>> it's
>> running Centos 5.
>> I guess I should just get the admin to update curl? Is that the actual
>> problem?
> I am not sure what the actual problem is. But in many cases,
> installing libcurl with the OS's package installer does seem to fix
> the problem.
> Dan

I got the admin to install the latest version of curl and the libcurl.so.4  
library file is now in /usr/local/lib but I still get the same error when  
trying to install RCurl on CentOS release 5.8 (Final):

gcc -std=gnu99 -shared -L/usr/local/lib64 -o RCurl.so base64.o curl.o  
curlInit.o curl_base64.o enums.o json.o memoryManagement.o myUTF8.o  
-L/usr/local/lib -lcurl -lxml2 -lz -lm
installing to /home/davetang/src/R-2.15.2/library/RCurl/libs
** R
** data
** inst
** preparing package for lazy loading
Creating a generic function for 'close' from package 'base' in package  
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded
Error in dyn.load(file, DLLpath = DLLpath, ...) :
   unable to load shared object  
   libcurl.so.4: cannot open shared object file: No such file or directory
Error: loading failed
Execution halted
ERROR: loading failed
* removing '/home/davetang/src/R-2.15.2/library/RCurl'

R version 2.15.2 (2012-10-26)
Platform: x86_64-unknown-linux-gnu (64-bit)

[1] C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] BiocInstaller_1.8.3

loaded via a namespace (and not attached):
[1] tools_2.15.2

I could install Rcurl and goseq on my own computer running Ubuntu precise  
by installing curl via apt-get.



More information about the Bioconductor mailing list