[BioC] Problem with importing bigWig file from GEO with rtracklayer?

Hollis Wright wrighth at ohsu.edu
Wed Aug 14 22:11:31 CEST 2013

Hi; I'm using rtracklayer to try to read in a bigWig file from a GEO dataset so I can overlay it on some existing data we have in GenomicRanges objects. Unfortunately, I keep running into the same error:

bw <- import(con="GSM1115998_Groseq-MCF7-EtoH-rep2.minusstrand.bigWig", format="bigWig")
Error in seqinfo(ranges) : UCSC library operation failed
In addition: Warning message:
In seqinfo(ranges) : End of file reading 4096 bytes (got 939)

I initially thought this was a problem with the file being corrupted, but I've both re-downloaded the archive and tried other files from it and received the same error every time. Any thoughts? sessionInfo below: 

R version 2.15.0 (2012-03-30)
Platform: x86_64-pc-mingw32/x64 (64-bit)

[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] rtracklayer_1.18.2   GenomicRanges_1.10.5 IRanges_1.16.4      
[4] BiocGenerics_0.4.0  

loaded via a namespace (and not attached):
 [1] Biostrings_2.26.2 bitops_1.0-4.2    BSgenome_1.26.1   parallel_2.15.0  
 [5] RCurl_1.95-3      Rsamtools_1.10.2  stats4_2.15.0     tools_2.15.0     
 [9] XML_3.95-0.1      zlibbioc_1.4.0


Hollis Wright, PhD
Ojeda Lab, Division of Neuroscience
Oregon Health and Science University

More information about the Bioconductor mailing list