[BioC] could not find function "makeProbePackage"

Merja Heinäniemi merja.heinaniemi at uef.fi
Sun Jun 9 17:33:07 CEST 2013


I am trying to build a custom probe package using the AnnotationDBI library and the function makeProbePackage. The script worked earlier (with R.2.12 at least) but now I get an error.
Error in eval(expr, envir, enclos) : 
  could not find function "makeProbePackage"

I get the error with R2.15.2 and Biobase_2.18.0 (see more details in session info below)

Did the function get replaced / removed ?  What should I do? Any other alternative than going back to earlier R and Bioconductor versions?

(in the same setting, building custom cdf worked but I would need the probe package for gcrma)

kind regards,

> sessionInfo()
R version 2.15.2 (2012-10-26)
Platform: x86_64-redhat-linux-gnu (64-bit)

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=C                 LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] AnnotationDbi_1.20.7 Biobase_2.18.0       BiocGenerics_0.4.0  
[4] makecdfenv_1.36.0    BiocInstaller_1.8.3 

loaded via a namespace (and not attached):
 [1] affy_1.36.1           affyio_1.26.0         DBI_0.2-7            
 [4] IRanges_1.16.6        parallel_2.15.2       preprocessCore_1.20.0
 [7] RSQLite_0.11.4        stats4_2.15.2         tools_2.15.2         
[10] zlibbioc_1.4.0  

More information about the Bioconductor mailing list