[BioC] Rbowtie - compilation error

Michael Stadler michael.stadler at fmi.ch
Thu Jun 5 14:08:40 CEST 2014

Hi Romain,

Please find my replies below:

On 05.06.2014 11:05, Romain Retureau wrote:
> Hi, 
> here is the output of uname -a :
> /"Linux retureau-MacBookPro 3.2.0-63-generic-pae #95-Ubuntu SMP Thu May
> 15 23:26:11 UTC 2014 i686 i686 i386 GNU/Linux//"/
> /
> /
> I didn't specify it, but i'm running ubuntu in dual bot on a mac book pro. 

> Here is the output of "make" inside the right folder : 
> http://pastebin.com/NZGX9YH0  (it's huge, that's why i'm using pastebin). 

> So I tried with this : "./bowtie --version" and get that :
> /"./bowtie version 1.0.1/
> /32-bit/
> /Built on retureau-MacBookPro/
> /jeudi 5 juin 2014, 10:57:41 (UTC+0200)/
> /Compiler: gcc version 4.8.1 (Ubuntu 4.8.1-2ubuntu1~12.04) /
> /Options: -O3 -m32  -Wl,--hash-style=both  /
> /Sizeof {int, long, long long, void*, size_t, off_t}: {4, 4, 8, 4, 4, 8}"/

Here I am confused. The 'make' output that you pasted shows that bowtie
is also failing to build, with the same error message as Rbowtie.

So it not possible to run './bowtie --version', because there is no
bowtie binary...

In the pasted output, I can find "... -DPOPCNT_CAPABILITY ...", while
the version below was compiled without that. Am I guessing correctly
that you compiled with:

Please let me know exactly what you do and where the output comes from,
otherwise it is difficult for me to help.


More information about the Bioconductor mailing list