[BioC] flowClean

Justin Meskas jmeskas at bccrc.ca
Fri Jun 20 00:41:04 CEST 2014

Hi Kipper,

Thank you for your quick reply. I had previously tried flowClean on uncompensated and untransformed data, and the same error was given.


From: Kipper Fletez-Brant [cafletezbrant at gmail.com]
Sent: June 19, 2014 3:26 PM
To: Justin Meskas
Cc: Ryan Brinkman; bioconductor at r-project.org
Subject: Re: flowClean

Hi Justin,

I'm cc'ing the Bioc list so that others having this problem might see this.

I have seen this error before. While it will take some time to diagnose, one comment I have is that we developed this algorithm to operate on uncompensated data. Try using flowClean before you do any other processing, and let me know how that works.


On Jun 19, 2014 5:42 PM, "Justin Meskas" <jmeskas at bccrc.ca<mailto:jmeskas at bccrc.ca>> wrote:
Hello Kipper,

I am in Dr. Ryan Brinkman's lab and I was trying to use your flowClean package. I have downloaded version 1.0.0 from Bioconductor and I received a similar error for many of my FCS files. I have attached one FCS file and the code I used to get the error. The error was the following:

Error in if (x == 0) { : missing value where TRUE/FALSE needed

I do not know if there is a problem with my data, or if I am using the data incorrectly with flowClean, but if there is any help you could provide me that would be greatly appreciated.

Thank you,

More information about the Bioconductor mailing list