[BioC] CummeRbund getGenes command broken in R?

Zain A Alvi zain.alvi at student.shu.edu
Fri Mar 7 04:47:50 CET 2014

Dear Dr. Goff,

I hope this reaches you well.  Thank you so much for the quick reply. I just checked everything, the myGeneIds contained two gene_short_names and I tried the common gene_ids from the same server where I acquired the *.FastA and *.gtf files. The same FastA and gtf files were used during previous parts of the Tuxedo package.   

I just tried again with gene_ids, but this time I copied for the specific genes from the gene_exp.diff file.  I think there was small difference between server ids for the genes versus the gene_exp.diff file. 
Sorry for such a novice mistake.  I really appreciate the fast reply and help.   


From: Loyal A. Goff <lgoff at csail.mit.edu>
Sent: Thursday, March 06, 2014 9:45 PM
To: Zain Alvi [guest]
Cc: bioconductor at r-project.org; Zain A Alvi
Subject: Re: CummeRbund getGenes command broken in R?

Hi zain,
Please confirm that MyGeneIds is a non-empty vector that contains valid gene ids or gene_short_names...


Loyal A. Goff
Postdoctoral Fellow
SCRB, Harvard

> On Mar 6, 2014, at 8:10 PM, Zain Alvi [guest] <guest at bioconductor.org> wrote:
> Dear Sir or Madam,
> I hope this reaches you well. I have been working with R and cummeRbund for the past few months. Everything seemed to be fine with the getGenes command in the manual.
> Apparently, today when I was trying to create a heatmap for my genes of interest. I would get the following error no matter what I have do:
>> myGenes <- getGenes(cuff,myGeneIds)
> Getting gene information:
>    FPKM
> Error in sqliteExecStatement(con, statement, bind.data) :
>  RS-DBI driver: (error in statement: near ")": syntax error)
> I am using latest version of cummeRbund with R. Also my Cuffdiff output was done through Cufflinks/Cuffmerge/Cuffdiff 2.0.2.
> I checked my old data, which has worked in the past and I received the same error, which is strange.
> Also I have reinstalled cummeRbund as well. I've rebuilt the database file as well. No matter, what I do I get this same error.
> If you could kindly help me. I would really appreciate it.
> Sincerely,
> Zain
> -- output of sessionInfo():
> R version 3.0.2 (2013-09-25)
> Platform: x86_64-w64-mingw32/x64 (64-bit)
> locale:
> [1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252
> [3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
> [5] LC_TIME=English_United States.1252
> attached base packages:
> [1] grid      parallel  stats     graphics  grDevices utils     datasets  methods   base
> other attached packages:
> [1] cummeRbund_2.4.1     Gviz_1.6.0           rtracklayer_1.22.4   GenomicRanges_1.14.4
> [5] XVector_0.2.0        IRanges_1.20.7       fastcluster_1.1.13   reshape2_1.2.2
> [9] ggplot2_0.9.3.1      RSQLite_0.11.4       DBI_0.2-7            BiocGenerics_0.8.0
> loaded via a namespace (and not attached):
> [1] AnnotationDbi_1.24.0   Biobase_2.22.0         biomaRt_2.18.0         Biostrings_2.30.1
> [5] biovizBase_1.10.8      bitops_1.0-6           BSgenome_1.30.0        cluster_1.14.4
> [9] colorspace_1.2-4       dichromat_2.0-0        digest_0.6.4           Formula_1.1-1
> [13] GenomicFeatures_1.14.3 gtable_0.1.2           Hmisc_3.14-3           labeling_0.2
> [17] lattice_0.20-23        latticeExtra_0.6-26    MASS_7.3-29            munsell_0.4.2
> [21] plyr_1.8.1             proto_0.3-10           RColorBrewer_1.0-5     Rcpp_0.11.0
> [25] RCurl_1.95-4.1         Rsamtools_1.14.3       scales_0.2.3           splines_3.0.2
> [29] stats4_3.0.2           stringr_0.6.2          survival_2.37-7        tools_3.0.2
> [33] XML_3.98-1.1           zlibbioc_1.8.0
> --
> Sent via the guest posting facility at bioconductor.org.

More information about the Bioconductor mailing list