[BioC] DESeq2: Error from the generic function 'plotMA' defined in package 'BiocGenerics'

David T. Auble dta4n at cms.mail.virginia.edu
Sun Mar 16 22:58:57 CET 2014

Mike, this is so helpful.  Thanks much!


On Sun, 16 Mar 2014 17:19:12 -0400
 Michael Love <michaelisaiahlove at gmail.com> wrote:
>​hi David,
>I'm adding the Bioconductor mailing list to my response in case other
>user's find the same error.
>Plotting the object res returned by results() is demonstrated in the
>vignette of the development branch, DESeq2 v1.3. This version will become
>the release branch in ~1 month. We created a simple class 'DESeqResults' on
>top of DataFrame, so that downstream packages can design methods specific
>for DESeq2 results objects.
>In the release branch (v1.2) you can produce an MA plot using the
>DESeqDataSet object:
>FYI, you can always pull up the vignette appropriate for your version by
>loading it from your R session:
>> I just don't understand how to make plotMA display the results.  Using the
>> command syntax that you provide:
>> plotMA(res,main="DESeq2",ylim=c(-2,2))
>> I get this error:
>> Error in plotMA(res, main = "DESeq2", ylim = c(-2, 2)) :
>>   Error from the generic function 'plotMA' defined in package
>> 'BiocGenerics': no S4 method definition for argument 'res' of class
>> 'DataFrame' was found. Did you perhaps mean calling the function 'plotMA'
>> from another package, e.g. 'limma'? In that case, please use the syntax
>> 'limma::plotMA'.
>> I have tried calling plotMA from limma as suggested, yielding:
>> Error in as.vector(data) :
>>   no method for coercing this S4 class to a vector

More information about the Bioconductor mailing list