[BioC] fasta biostrings bioconductor

Hervé Pagès hpages at fhcrc.org
Fri Mar 28 20:21:35 CET 2014

Hi there,

I guess you're trying to use DNAStringSet() on a file name that contains
a "p", which of course is not going to work (and even if it worked, it
wouldn't do what you're trying to do).

To read a FASTA file, use readDNAStringSet(), not the DNAStringSet 
constructor function.


On 03/28/2014 09:43 AM, DNAStringSet Error Biostrings in R [guest] wrote:
> I posted this same quandary on Biostars and stack overflow.
> I am attempting to import a fasta file of sequences into R using Bioconductor's 'Biostrings' package and the 'DNAStringSet' function but I keep getting the same error:
> Error in .Call2("new_XString_from_CHARACTER", classname, x, start(solved_SEW),  :
> key 112 (char 'p') not in lookup table
> My fasta file ("FileName.fa") is comprised of various length sequences, in the following format:
>> GeneNameOne
>> GeneNameTwo
> ...etc
> I performed 'grep p FileName.fa' in the Unix terminal, but I received no output.
> Does anyone have an idea on what is going on?
> Thanks in advance.
>   -- output of sessionInfo():
> Error in .Call2("new_XString_from_CHARACTER", classname, x, start(solved_SEW),  :
> key 112 (char 'p') not in lookup table
> --
> Sent via the guest posting facility at bioconductor.org.
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at r-project.org
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: hpages at fhcrc.org
Phone:  (206) 667-5791
Fax:    (206) 667-1319

More information about the Bioconductor mailing list