R-alpha: a question on terminology

Kurt Hornik Kurt.Hornik@ci.tuwien.ac.at
Fri, 22 Aug 1997 14:39:52 +0200

>>>>> Martin Maechler writes:

>>>>> "Kurt" == Kurt Hornik <hornik@ci.tuwien.ac.at> writes:

Kurt> Whereas we typically refer to the add-on `modules' as `libraries' (viz
Kurt> also the way these are represented in the search list, and the variable
Kurt> .Libraries), S speaks about `sections'.

> [.Libraries are not used anymore ...
>  search() & .Provided should be enough, ...]

Kurt> Shall we stay with our terminology?

> I think so.

Kurt> Or instead, speak of `sections',
Kurt> Shall we stay with our terminology?  Or instead, speak of `sections',
Kurt> `packages', `modules', ...?

> Or use something which S does not use at all,
> since 'require(.);  provide(.)' and  Thomas Lumley's  
> autoload(..) features enable an entirely different approach.

Thanks to Martin and Ross for the immediate response.

Ross wrote,

> I like "packages".  Modules have namespace implications which the
> present setup does not provide.

I guess we have a decision then, and will refer to an `add-on' as a

	>>> PACKAGE <<<

E.g., the PACKAGE `mva', ...

(And hope than when R conquers the world there will be real modules.)

To make things consistent, could we PLEASE make the corresponding
changes so that search() shows


rather than "library:base"?

Locations I found were

	STRING(ans)[n-1] = mkChar("library:base");

	suicide("unable to open the base library\n");

and in src/library/base/funs/library

I will meanwhile change things in the FAQ accordingly.

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch