R-alpha: RData in batch

Philippe Lambert phlamber@luc.ac.be
Thu, 27 Nov 1997 11:02:26 +0100 (MET)

Just a word to mention that I have lost 2 hours yesterday to find out why
R refused to use a function from a package calling C-code.
R invariably answered that the C code was not in the load table (something
like this). I have tried everything (or nearly) to solve my problem
knowing that this same package used to work on my computer at the
Finally, I found out that running the same instructions as root work fine.
The explanation for my computer sudden good will is not that I was root,
but that I ran R in a different directory ... without .RData!!
(and I don't care about .RData when I use R in batch mode!!).

would it be possible to have R not creating .RData file by default in
batch mode?

A second potential problem: when I build packages including personal
functions, I use to test my functions interactively by typing
library(mypackage) after modification of my code in an editor.
The problem is that repeating the library load does not erase the old
version. Do I do something wrong?


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch