0.65 && AIX|HPUX

Kurt Hornik Kurt.Hornik@ci.tuwien.ac.at
Wed, 14 Jul 1999 17:18:46 +0200 (CEST)

>>>>> Martin Maechler writes:

KH> I've made some more changes to configure/make which still don't solve
KH> everything but I think I have to stop for now.

> too bad (the "stop for now").

(Well, the point is that the experimental approach is very inefficient.
We need someone who really knows about these platforms.)

KH> Status AIX:

KH> * I can compile with gcc/f77/make.
KH> * AIX make check fails (cannot build base-Ex.R).
KH> * GNU make check fails in the contour example.
KH> * Plotting is broken (tickmarks go all the way thru).

> This is exactly the typical result of the next item : In my
> experience, whenever is.finite(), finite() 1/0, 0/0 etc weren't ok
> (and as Peter emphasized, they are *not at all* as long as you get
> "INF" and "NaNQ" instead of "Inf" and "NaN") then the graphics show
> the above symptome.

Hmm.  Perhaps we can nail that down.  My impression was that the finite
et al tests I tried were o.k.  Do you know what exactly causes the
plotting problem?

> The way that I found that -D_XOPEN_SOURCE_EXTENDED
> will save me, was by looking into /usr/include/math.h

> It seems that you (and Thomas Vogels !) have a different one, than,
> even though Thomas said that he had AIX 4.2 as well?  This is what I
> have :

>     $ uname -a
>     AIX percol 2 4 000333104600

>     $ ls -l /usr/include/math.h
>     -r--r--r--   1 bin      bin        14620 Oct 14 1996  /usr/include/math.h

> What versions of AIX 4.2 are around?

I have

e8725245@fbma:/home2/e8725245$ uname -a
AIX fbma 2 4 000147825700
e8725245@fbma:/home2/e8725245$ ls -l /usr/include/math.h 
-r--r--r--   1 bin      bin        14620 Oct 14 1996  /usr/include/math.h


e8725245@fbma:/home2/e8725245$ ls -l /usr/bin/f77 
-rwxr-xr-x   3 bin      bin        99453 May  7 1998  /usr/bin/f77*
e8725245@fbma:/home2/e8725245$ gcc --version
e8725245@fbma:/home2/e8725245$ gmake --version
GNU Make version 3.77, by Richard Stallman and Roland McGrath.

KH> * IEEE fp stuff is strange (will look into this).
KH> * I still need f77 for linking.  Using ld with the suggested flags gives
KH> a binary with `exec format error'.  The problem seems to be with an
KH> unreferenced __start.
KH> * The basic add-ons seem to work, though.

KH> Status HPUX:

KH> * I can compile the main binary with c89/f77/make.
KH> * Compilation fails in eda (syntax error in etc/Makeconf).  The problem
KH> disappears when the SHLIB target is commented ... but then building
KH> the shared lib fails.  I tried xlispstat -Wl,-E instead but no.
> 				       ~~~~~~~~~
> 				       sure about that ??

3-52-5 configure has

      UCFLAGS="$UCFLAGS -Imachines/hpux/dlfcn"
      EXTRAOBJS="$EXTRAOBJS dlfcn.o"
      link_sources="$link_sources machines/hpux/dlfcn/dlfcn.c"
      link_targets="$link_targets dlfcn.c"

KH> * QUESTION: what about src/unix/hpdlfcn.c?

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch