Installation of package fails (PR#328)
Tue, 16 Nov 1999 15:21:35 +0100 (MET)

Full_Name: Thomas Langhans
Version: 0.65
OS: Solaris 7
Submission from: (NULL) (

I tried to install the package "leap" on our Sun Enterprise 400 running Solaris
but it fails: cause the g77 doesn't compiles the fortran-sources properly, I 
translated them with f2c to c-source.
Running R INSTALL produces the following message:
Installing package `leaps' ...
gcc -g -O2 -fPIC -I/sw/sun4_55/R-0.65.0/lib/R/include -c leaps.c -o leaps.o
gcc -g -O2 -fPIC -I/sw/sun4_55/R-0.65.0/lib/R/include -c leapshdr.c -o
ld -G -o /sw/sun4_55/R-0.65.0/lib/R/library/leaps/libs/ leaps.o
leapshdr.o -lF77 -lI77
 >>> Building/Updating help pages for package `leaps'
     Formats: text html latex example 
 DONE (leaps)

So anything seems to be fine. But any time I load the library, R raises an

> library(leaps)
Error in dyn.load(file) : unable to load shared library
"/sw/sun4_55/R-0.65.0/lib/R/library/leaps/libs/": /sw/sun4_55/R-0.65.0/lib/R/bin/R.binary: fatal: relocation error:
file /sw/sun4_55/R-0.65.0/lib/R/library/leaps/libs/ symbol sig_die:
referenced symbol not found

The same error do I get when I install the package "ppr". Other packages work

I hope somebody can help me, cause these librarys are very important for a
running project
at our departement.

r-devel mailing list -- Read
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: