Installation of package fails (PR#328)
Tue, 16 Nov 1999 17:21:19 +0100 (MET)

> From:
> Date: Tue, 16 Nov 1999 15:21:35 +0100 (MET)
> To:
> Subject: Installation of package fails (PR#328)
> CC:
> X-Loop:
> Full_Name: Thomas Langhans
> Version: 0.65
> OS: Solaris 7
> Submission from: (NULL) (
> I tried to install the package "leap" on our Sun Enterprise 400 running 
> 7,
> but it fails: cause the g77 doesn't compiles the fortran-sources properly,

What is the error message?  They work for me.

>  I translated them with f2c to c-source.
> Running R INSTALL produces the following message:
> Installing package `leaps' ...
>  libs
> gcc -g -O2 -fPIC -I/sw/sun4_55/R-0.65.0/lib/R/include -c leaps.c -o leaps.o
> gcc -g -O2 -fPIC -I/sw/sun4_55/R-0.65.0/lib/R/include -c leapshdr.c -o
> leapshdr.o
> ld -G -o /sw/sun4_55/R-0.65.0/lib/R/library/leaps/libs/ leaps.o
> leapshdr.o -lF77 -lI77

Are those the libraries for g77? They look like those for f77 to me.
Do you have the current version (2.0) of leaps?  Does by any chance 
leaps/src/Makefile exist?  If so try deleting it.

AFAIK g77 on Solaris should have -lg2c -lm in FLIBS: that is what 
my installation (gcc-2.95 on Solaris 2.6) gives. If you use f2c, you
need -lf2c -lm.

> The same error do I get when I install the package "ppr". Other packages work
> fine.

Um. That is obselete, and its code is in package modreg, which must
have been installed at the original build. So that suggests your setup
is OK, but that a Makefile is wrong.

If you really get stuck I can let you have a pre-compiled version for leaps.

Brian D. Ripley,        
Professor of Applied Statistics,
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-devel mailing list -- Read
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: