[Rd] multiply defined symbols (PR#597)

Peter Dalgaard BSA p.dalgaard@biostat.ku.dk
07 Jul 2000 16:46:02 +0200

plucas@csd.abdn.ac.uk writes:

> I tried to install R 1.1.0 on my i686 PC with Redhat 6.2 Linux on it.
> I am using fort77 with f2c. I am not able to build R, as libc.a contains
> regex.o, causing a conflict with src/main/regex.o. the ONEWS mentions
> that this problem was solved, but it obviously was not. I am not a real
> Unix hacker, so I wonder how to proceed.

One possibility would be to use f2c directly. Pseudo Fortran compilers
like fort77 (which is just a script around f2c) do strange things
occasionally. Use the --with-f2c flag to configure.

The egcs-g77 package that comes with RH6.2 should work for compiling R
itself, but seems to be having trouble with some add-on packages.
gcc-2.95.1 and later seems to be OK.

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)             FAX: (+45) 35327907
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch