[Rd] Re: [R] Compiling R on RS6000 AIX 4.3

Kurt Hornik Kurt.Hornik@ci.tuwien.ac.at
Wed, 12 Jul 2000 22:23:07 +0200

>>>>> Thomas Lumley writes:

> On Wed, 12 Jul 2000, Martin Maechler wrote:
>> >>>>> "Peter" == Peter Cameron <peter.cameron@enscitech.com> writes:
Peter> I've been searching through the R help archives and came across
Peter> only one AIX compilation question in March, which received no
Peter> public responses. I'm currently having the same problems with
Peter> the "Illegal instruction" and core dump of running R 1.0.1 on
Peter> AIX 4.3.
Peter> Firstly, the R distribution was missing some FORTRAN routines,
>> No!
>> You didn't search enough.

> I think it's more complicated than that.  The last time I tried
> compiling R on AIX there was a configure problem with the BLAS
> functions.  The library libblas existed but the functions had the
> wrong names (due to differences in use of underscores by fortran
> compilers). This meant that R didn't compile its own BLAS but couldn't
> link to the system one either. I thought this had been fixed, though.

> I got it to work using gcc/g77 and compiling --without-blas.  I don't
> know if the people at CMU who use AIX have more options that work.

> There is a real problem with some C/Fortran combinations on AIX.

Hmm.  Is the problem still there in release-patched?

We have

	if test "${r_cv_prog_f77_append_underscore}" = yes; then

and then

	if test -n "${BLAS}" && ${use_blas}; then
	  AC_CHECK_LIB(blas, ${fun},
	    [ FLIBS="-lblas ${FLIBS}" BLAS=""
	      if ${use_blas_risc}; then
	        AC_CHECK_LIB(blas_risc, main,
		  FLIBS="-lblas_risc ${FLIBS}", , ${FLIBS})
	    ], ,

so if the test whether the Fortran compiler appends underscores worked
o.k. then we should be checking for the correct symbol.

So, what is wrong?

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch