[Rd] R with redhat 7 (PR#732)

hyu@stats.uwo.ca hyu@stats.uwo.ca
Wed, 8 Nov 2000 22:32:49 +0100 (MET)

Full_Name: Hao Yu
Version: 1.1.0 and 1.1.1
OS: Redhat 7 Linux (intel)
Submission from: (NULL) (

Hi, I am not sure this is well know problem but I could not find anyone mention
The problem is related to build R on redhat 7. After got src.rpm and tried to
rebuild it, it failed on testing accuracy. Further it shows that under R,
.Machine gives some numbers that maybe are not correct. I also tried the most
recent one (November 6) and failed. The strange thing is that the R (1.1.0) that
comes with powertools of redhat 7 has exactly the same problem. All three R
gives the same results for .Machine. See the following outputs. 

Hao Yu

PS. One system has Pentium III 600Mhz and 256RDRAM, Intel CC820 motherboard;
    Another has Pentium III 800Mhz and 256 SDRAM, ASUS BX motherboard.

R : Copyright 2000, The R Development Core Team
Version 1.1.1 Patched (November 6, 2000)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type    "?license" or "?licence" for distribution details.

R is a collaborative project with many contributors.
Type    "?contributors" for a list.

Type    "demo()" for some demos, "help()" for on-line help, or
        "help.start()" for a HTML browser interface to help.
Type    "q()" to quit R.

> .Machine
[1] 1.084202e-19

[1] 5.421011e-20

[1] 0.25

[1] 0.5

[1] 2

[1] 64

[1] 5

[1] 0

[1] -63

[1] -64

[1] 1

[1] -2

[1] -2

[1] 2147483647

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch