[Rd] Problem with Rcmd check

Prof Brian D Ripley ripley@stats.ox.ac.uk
Wed, 18 Apr 2001 06:32:32 +0100 (BST)

On Tue, 17 Apr 2001, Duncan Murdoch wrote:

> In Windows, I tried to build and check Paul Gilbert's dse bundle with
> the command
>  rcmd check ../library/dse
> It ran for a while and built the packages, then failed at the end with
> this:
>  ** checking Rd files ... OK
>  ** checking for undocumented objects ... OK
>  ** creating syskern-Ex.R ... ERROR
> I get similar errors checking packages, but there
>   make pkgcheck-foo
> works.  I don't think there's a "bundlecheck-foo" target, is there?

No, but you can check individual packages in a bundle (just set the
PKGDIR).  However, there is a bug if a package has a tests directory, and
it can be fixed by altering the RDIFF line near the top of
src/gnuwin32/check/PkgCheck to be

RDIFF = $(RHOME)/bin/Rcmd Rdiff.sh

(This is fixed in the patched versions.  Rdiff got altered fairly recently
and broke this.)

> Any workarounds, or hints where I should look to figure out what went
> wrong?

I think this is a Perl problem we have seen before.  It works for me on NT
(and I think worked for Uwe Ligges too).  Earlier versions (build 613, for
example) of Perl used to work on Win 98, but from ca 619 this happened.
The problem relates to the shell used by the system() command in Perl.

Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch