[Rd] R-1.3.0-1.3.1.diff does not patch correctly

Peter Dalgaard BSA p.dalgaard@biostat.ku.dk
03 Sep 2001 11:58:39 +0200

wb@vestein.arb-phys.uni-dortmund.de (Wilhelm B. Kloke) writes:

> Subj. says it. The patch contains several lines complaining about "No newline".
> After removing these the patch was applicable.

Odd. This worked cleanly when I tried it on RedHat 7.1. What version
of patch is this?

The offending lines are flagged with a \ in col.1, which is
undocumented in the info file for diff, but obviously discernible from
ordinary unidiff lines (which have either space, + , or - ). So I
suspect that a recent "patch" just treats that as a comment.

Looks like the problem could be difficult to avoid (except by ensuring
that we don't have any files without terminal newlines) since I see no
diff option controlling the behaviour.

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)             FAX: (+45) 35327907
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch