Inconsistent use of Perl? (PR#1937)

Prof Brian D Ripley
Sat, 24 Aug 2002 21:43:21 +0100 (BST)

On Sat, 24 Aug 2002 wrote:

> Dear all
> yesterday I got around to install R-1.5.1 on my machine at home which,
> admittedly, is running a very old version of RedHat Linux.  I noticed
> two things:
> 1) My pdflatex version is too old to produce the pdf version of the
>    manuals.  `./configure' checks whether a recent version of makeinfo
> is installed and tells you whether you can produce the info version or
> not.  (I was told I couldn't, another reason to upgrate the machine.)
> But during configuration there don't seem to be any check whether the
> pdflatex is recent enough.  You might want to consider to add such a
> check.

Well, we would need to know which version failed.  What is yours?

doc/manuals/README mentions pdftex-0.14d.  *ANY* version older than 1.00
is unreleased and experimental, but versions as old as -0.13d have worked.

> 2) `./configure' checks whether Perl 5.004 (or later) is installed.
>    On my machine Perl 5.00405 is installed and the installation went
> ahead without problems.  However, when I then tried to install
> R-1.5.1-recommended by issuing the command
>         R CMD INSTALL *.tar.gz
> in the appropriate directory, I received complaints about my Perl
> version.  Essentially, R wanted all of a sudden Perl 5.005 (or
> later).  An edited version of what I saw on my terminal is included
> below.  I got the same kind of error message when I used from within R
> `update.packages' and `install.packages' to update/install some
> packages that are not in R-1.5.1-recommended.
> As far as I can tell, the installation of the packages went ahead fine
> except that the `TITLE' file for each of these packages is empty.
> Hence, I guess the error message is produced when R tries to generate
> and install the `TITLE' file.  However, the `TITLE' files for the
> packages in the base distribution are fine.  This leaves me wondering
> why during the base installation Perl 5.004 (or later) is good enough
> for producing the `TITLE' file but for `R CMD INSTALL' Perl 5.005 (or
> later) is required.

That is correct.  Most things require 5.004, a few require 5.005.
Why is that a bug?

The issue is the use of the Text::Wrap module in share/perl/R/,
where 5.004_05 was broken (we discovered).

Brian D. Ripley,        
Professor of Applied Statistics,
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-devel mailing list -- Read
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: