[Rd] R 1.4.0 build fails on AIX (PR#1289)

Dan Million lio@hpss1.ccs.ornl.gov
Tue, 19 Feb 2002 15:36:01 -0500 (EST)

On 19 Feb 2002, Thomas Vogels wrote:

> - have you tried gcc instead of xlc?  It's surprisingly easy to
>   install for AIX.
> - have you tried to turn off all optimizations (explicitly if needed)?

I have gcc; the trouble is I don't have g77, and I don't want to mix gcc
objects with IBM XL Fortran objects in the same library.

> My AIX box also has ML 9 but I'm not using xlc but gcc.  And I haven't
> seen a problem yet.
> > By the way, my user has emphasized that they really need the R shared
> > library.  And if I build with --enable-R-shlib, then chunks of R simply
> > don't work at all (like the X11 support).  Ah well....
> I could try building the shared lib.  But without knowing that you
> could switch to gcc, I wouldn't help.  (I can't run xlc).

I'm finding more and more problems with the R shared library.  I don't
think it's being built correctly at all.


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch