[Rd] c-c problem when R compiled with pthread

Liaw, Andy andy_liaw@merck.com
Fri, 22 Feb 2002 12:59:35 -0500

Dear R-devel,

I've run into this problem that when I hit c-c to interrupt a command or
computation, the R session just ends.

The info: R-1.4.1 compiled from source on Linux Mandrake 7.1.  Dual P-3 Xeon
with 2GB ram.

1.  Compiled R with link to Intel Math Kernel Library (for fast BLAS), which
needed pthread.  C-c at the R prompt ends the R session.

2.  Compiled R with link to (threaded) ATLAS, which again needed pthread.
Same thing happened.  However,
I tried running this version of R under ESS, and c-c c-c works fine.
Pressing the "interrupt" button in the R gnome interface also worked fine.

3.  Compiled R without link to MKL or ATLAS.  C-c works as expected.

This seems to suggest pthread as the problem.  Can anyone offer


Andy I. Liaw, PhD
Biometrics Research          Phone: (732) 594-0820
Merck & Co., Inc.              Fax: (732) 594-1565
P.O. Box 2000, RY70-38            Rahway, NJ 07065

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch