configure for R 1.5.x on Solaris (fwd)

H C Pumphrey
Tue, 25 Jun 2002 09:41:04 +0100 (BST)

Dear All, 

No-one seemed to know about this on r-help, so I'm trying here.... 

I'm having problems at the configure stage when trying to build R on
Solaris 5.8. configure finds everything it needs but when it runs
config.status to make all the Makefiles and headers, I get a huge slew of
errors like this:

config.status: creating src/extra/zlib/Makefile
sed: -e expression #1, char 329: Unterminated `s' command
sed: file /tmp/cs6134-11745/subs-1.sed line 38: Unterminated `s' command
config.status: creating src/include/Makefile
sed: -e expression #1, char 323: Unterminated `s' command
sed: file /tmp/cs6134-11745/subs-1.sed line 38: Unterminated `s' command

...and so on. I have tried replacing Solaris's native sed with GNU sed (in
fact the above messages are from GNU sed but Solaris sed fails in a
similar way). I have also tried setting CONFIG_SHELL to /foo/bar/bin/bash
to force configure not to use solaris's cheesy /bin/sh . No success, so
now I am at a loss. The problem occurs with R-1.5.0 but not with R-1.4.1
(and of course there is no problem on my Linux box!)

Any ideas welcome.


Dr. Hugh C. Pumphrey             | Tel. 0131-650-6026,Fax:0131-650-5780
Institute for Meteorology        | Replace 0131 with +44-131 if outside UK
The University of Edinburgh      | Email
EDINBURGH EH9 3JZ, Scotland      | URL:

r-devel mailing list -- Read
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: