[Rd] R-1.7.0-beta: in check-all test-IsAs fails on WinNT4.0

Uwe Ligges ligges at statistik.uni-dortmund.de
Sat Apr 12 20:50:08 MEST 2003

Todays R-1.7.0-beta (see below) compiles fine on, but it doesn't pass
  make check-all
on WinNT4.0, SP6.

Looking closer, test-IsAs fails:

D:\uwe-ns\R-1.7.0\tests>make -f Makefile.win test-IsAs
running tests of consistency of as/is.*
make[1]: Entering directory `/cygdrive/d/uwe-ns/R-1.7.0/tests'
creating 'isas-tests.R'
make[1]: *** [isas-tests.R] Error 253
make[1]: Leaving directory `/cygdrive/d/uwe-ns/R-1.7.0/tests'
make: *** [test-IsAs] Error 2

Rterm crashes with a "stack overflow".

The strange thing: I can run the test manually without any problems (I 
tried to invoke rterm the same way as in the makefiles -- well, 
apparently I just *tried*)!
It looks like the file "isas-tests.R" which should be sink()ed in 
"isas-tests.Rin" won't be created. Any ideas?

Uwe Ligges

platform i386-pc-mingw32
arch     i386
os       mingw32
system   i386, mingw32
status   Under development (unstable)
major    1
minor    7.0
year     2003
month    04
day      12
language R

More information about the R-devel mailing list