[Rd] R-1.7.0-beta: in check-all test-IsAs fails on WinNT4.0

Uwe Ligges ligges at statistik.uni-dortmund.de
Wed Apr 16 12:39:46 MEST 2003

Uwe Ligges wrote:
> Uwe Ligges wrote:
>> Todays R-1.7.0-beta (see below) compiles fine on, but it doesn't pass
>>  make check-all
>> on WinNT4.0, SP6.
>> Looking closer, test-IsAs fails:
>> D:\uwe-ns\R-1.7.0\tests>make -f Makefile.win test-IsAs
>> running tests of consistency of as/is.*
>> make[1]: Entering directory `/cygdrive/d/uwe-ns/R-1.7.0/tests'
>> creating 'isas-tests.R'
>> make[1]: *** [isas-tests.R] Error 253
>> make[1]: Leaving directory `/cygdrive/d/uwe-ns/R-1.7.0/tests'
>> make: *** [test-IsAs] Error 2
>> Rterm crashes with a "stack overflow".
>> The strange thing: I can run the test manually without any problems (I 
>> tried to invoke rterm the same way as in the makefiles -- well, 
>> apparently I just *tried*)!
> Yep. I did it again (and hopefully correct) and in the following case 
> Rterm.exe crashes with a stack overflow:
> D:\uwe-ns\R-1.7.0\tests>d:\uwe-ns\r-1.7.0\bin\rterm --vanilla --slave 
> LC_ALL=C SRCDIR=. < isas-tests.Rin
> which is the way R is called in the Makefile for test-IsAs, AFAICS.
> I know, it's much too late for this report, but in fact I was too busy 
> with an S course during the last 7 days to look closer. Sorry.

Sorry for wasting bandwidth:
The problem already seems to be resolved in yesterdays beta!

But there is still another one in .../tests/Makefile.win:

     @echo "---- checking base packages ----"
     @for p in $(R_PKGS_BASE); do \
       echo ; \
       echo "* checking package '$${p}'"; \
       rcmd check ../src/library/$${p} || echo; \

In the last but one line of the given code, rcmd won't be found if the 
path is not specified! Instead that line should read:

$(RHOME)/bin/rcmd check ../src/library/$${p} || echo; \

Uwe Ligges

More information about the R-devel mailing list