[Rd] Problem with Rcmd check and S4 methods

John Chambers jmc at research.bell-labs.com
Fri Jun 13 16:04:44 MEST 2003

Duncan Murdoch wrote:
> On Fri, 13 Jun 2003 13:18:23 -0400, you wrote:
> >It would be nice to be able to get a dump from the R CMD check
> >evaluation--maybe someone can suggest how.
> If I just cut all the preamble from the Rout file and paste it into
> the console, I get the same error.  Here's a traceback(), I'm not sure
> what you mean by a dump.
> Duncan
> >  x <- eulerzyx(1,0,0)
> Error: Trying to get slot "validity" from an object of a basic class
> ("NULL") with no slots
> > traceback()
> 5: validObject(.Object)
> 4: initialize(value, ...)
> 3: initialize(value, ...)
> 2: new("eulerzyx", x = cbind(psi, theta, phi))
> 1: eulerzyx(1, 0, 0)

I think the problem is from not using a saved image.  Using your tar
file, if I untar into orientlib/, I get the same error you report.  But
after creating the install.R file:

guinan[RPackages]$ touch orientlib/install.R

the error in this example goes away.  (There is a later error:

> x <- rotvector(matrix(c(1,0,0,0,1,0,0,0,1)))
Error: ncol(m) == 9 is not TRUE

but I'm guessing this may be more local :-)

Hopefully for 1.8 we will get rid of the differences between saved image
and ordinary loading (except that the latter will still be slower for
packages doing much with classes and methods).


John M. Chambers                  jmc at bell-labs.com
Bell Labs, Lucent Technologies    office: (908)582-2681
700 Mountain Avenue, Room 2C-282  fax:    (908)582-3340
Murray Hill, NJ  07974            web: http://www.cs.bell-labs.com/~jmc

More information about the R-devel mailing list