[Rd] R postscript generation error (lines versus points) (PR#5285)

Stephen.Harker at spme.monash.edu.au Stephen.Harker at spme.monash.edu.au
Tue Nov 25 00:29:59 MET 2003


On Tue, Nov 25, 2003 at 09:17:09AM +1300, Paul Murrell wrote:
> Peter Dalgaard wrote:
> > Stephen.Harker at spme.monash.edu.au writes:
> >>Full_Name: Stephen Harker
> >>Version: 1.80
> >>OS: linux (Yellow Dog 3.0 on ppc)
> >>Submission from: (NULL) (
> >>
> >>
> >>In creating a postscript file from a set of data in which the points are
> >>plotted
> >>using `points()' and lines drawn using `lines()' I have found since 
> upgrading
> >>from R version 1.4? to 1.8 that the two sets do not coinicide 
> completely.  [...]
> > [At the current rate, "1.80" would be about 36 years into the future.
> > Latest version is 1.8.1.]


> > I can't reproduce this with 1.8.0 on RedHat 8.0. Are you sure it isn't
> > your Postscript viewer that is playing tricks on you??

Yes and no: I get the same result in prints from a PostScript file or
from files included into a LaTeX document in the case of the original
scripts that caused me to try to create a test case.  However, this
morning having read this comment I tried this test script and I find
it generates obvious `errors' using gs 8.11 (in /usr/local/bin) and
none obvious using the system gs (7.05 in /usr/bin).  I tried printing
the file to a HP Laserjet 4MV, 8000N and a Konica 7155 and find it is
similar to the gs 7.05 output.  This suggests two problems: a problem
with gs 8.11 as built on my system and that my test script does not
duplicate the problem I thought I was illustrating.

In the production scripts I have been using (with a history that goes
back to the mid 90's) this occurs in a vary obvious mismatch in the
lines() and points() that gets worse as x increases.  I had thought
that the script submitted duplicated the problem.  Now it appears that
it does not.  For the scripts I was using I get the mismatch on
printed postscript and similar(? I did not compare them fully) results
with the screen.  

> I can't reproduce this either, but in trying your script I wonder if you 
> are not properly "finishing" the postscript plot by calling dev.off 
> before viewing.  If I run your script, then view R-test2.ps without 
> quitting R, the last few points at the right end of the plot are missing 
> (because the postscript file is not yet complete).  If I then quit R 
> (the postscript file is completed and closed), the postscript output 
> looks just like the X11 version.

No: in my production versions dev.off() is called.  I noticed the
missing points you mentioned in the postscript file created.  However,
I did not worry about it as the error was noticeable in the alignment
of the `peaks' and `points' prior to the missing points.

I will need to test this further and to find a better way of
duplicating the error (if error it is).  I will have to try building R
1.8 on another system and test my Rietveld and other x-ray data
plotting scripts to see if it matches my current problem.  I will
contact you when I have more data (useful or otherwise).  

Stephen Harker                           Stephen.Harker at spme.monash.edu.au
School of Physics & Materials Engineering
Monash University                       http://www.ph.adfa.edu.au/s-harker/
                                 Baloney Baffles brains: Eric Frank Russell

More information about the R-devel mailing list