[Rd] make check failed for R-1.9.0alpha (2004-03-16) when link against Goto's BLAS

Liaw, Andy andy_liaw at merck.com
Tue Mar 16 19:36:29 MET 2004

Dear all,

Has anyone seen the same problem?  I tried compiling R-1.9.0 alpha
(2004-03-16) on our Opteron box running SUSE Linux ES8.  I ran:

./configure --enable-R-shlib --with-blas=goto

and got:

  Source directory:          .
  Installation directory:    /usr/local

  C compiler:                gcc  -m64 -O2 -g -msse2 -march=k8 -Wall
  C++ compiler:              g++  -m64 -O2 -g -msse2 -march=k8 -Wall
  Fortran compiler:          g77  -m64 -O2 -g -msse2 -march=k8

  Interfaces supported:      X11, tcltk
  External libraries:        readline, BLAS(generic)
  Additional capabilities:   PNG, JPEG
  Options enabled:           shared library, R profiling

  Recommended packages:      yes

(The Goto BLAS is libgoto_opt64-r0.93.so.)

"make" ran fine, but "make check" failed with tail
tests/Examples/stats-Ex.Rout.fail giving:

> ## now see the effect of the explanatory variables
> data(Seatbelts)
> X <- Seatbelts[, c("kms", "PetrolPrice", "law")]
> X[, 1] <- log10(X[, 1]) - 4
> arima(log10(Seatbelts[, "drivers"]), c(1,0,0),
+       seasonal = list(order= c(1,0,0)), xreg = X)
Error in La.svd(x, nu, nv, method) : error code 3 from Lapack routine dgesdd
Execution halted

If I do "make clean" and re-configure without the Goto BLAS, then it passes
make check.  Does anyone know what I'm doing wrong?  Any help much


Andy Liaw, PhD
Biometrics Research      PO Box 2000, RY33-300     
Merck Research Labs           Rahway, NJ 07065
mailto:andy_liaw at merck.com        732-594-0820

Notice:  This e-mail message, together with any attachments,...{{dropped}}

More information about the R-devel mailing list