[Rd] having trouble building r-devel

Mark.Bravington at csiro.au Mark.Bravington at csiro.au
Wed Sep 8 09:44:30 CEST 2004

Aha-- thanks!

>> Or I've
>> gotten my wires crossed...
>The latter.  Try commenting out
># path (possibly full path) to same version of R on the host system
># R_EXE=R
>in MkRules.  It's uncommented there from experiments with 
>Works for me.

Yes, it's just worked for me too. Is it worth mentioning this in the INSTALL file after the sentence that says "IMPORTANT: edit MkRules to set the appropriate paths..."? [It may be that all my builds hitherto have actually invoked an earlier version of R than the one being built, but that this never mattered before.]

>> So it looks like either (i) the documentation should be 
>changed to tell
>> the user to reset the path manually (and NB the dot isn't useful for
>> Windows 2000), 
>It was when I ran Windows 2000.  What's wrong for you?

Just that, at the moment of running "make", the dot refers to src\gnuwin32, which doesn't pick up the R.exe file. With the commenting-out above, "make" now works fine for me now whether or not PATH starts with a dot. [I thought MS-DOS implicitly put a dot in, i.e. doesn't it always look for EXEs and BATs in the current directory first?] I think I need to start the path with <<current-R-version>>\bin  rather than dot.

>Brian D. Ripley,                  ripley at stats.ox.ac.uk
>Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
>University of Oxford,             Tel:  +44 1865 272861 (self)
>1 South Parks Road,                     +44 1865 272866 (PA)
>Oxford OX1 3TG, UK                Fax:  +44 1865 272595


Mark Bravington
PO Box 1538
Castray Esplanade
TAS 7001

phone (61) 3 6232 5118
fax (61) 3 6232 5012
Mark.Bravington at csir

More information about the R-devel mailing list