[Rd] Re: Packages and Libraries (was: Re: lme4 "package" etc ..)

Peter Dalgaard p.dalgaard at biostat.ku.dk
Wed Feb 9 16:55:31 CET 2005

Kurt Hornik <Kurt.Hornik at wu-wien.ac.at> writes:

> >>>>> A J Rossini writes:
> > But I don't see a problem with "package("package")", though I'm sure
> > I'm missing something.
> package() [sic] might be the creator for package objects, provided we
> can decide on what they are (and what kind of packages [source,
> installed, ...] they are used for).
> usePackage() or use_package() otoh would indicate to "use" a package
> (i.e., load and attach it).  The tricky part is deciding about the
> interface (e.g., finally disallowing non-standard evaluation as it is a
> programmer's nightmare) and what it should return.  And that is work in
> progress ...

Any information on the rate...? (I still vote for usepackage() btw.)

It would be good if we could at least have an outline of the intended
functionality and see if we could forge ahead and get a preliminary
version done in time for 2.1.x
> Even if we don't like the current semantics, the *name* of library() in
> itself should not be a problem.  After all, calling summary() does not
> imply that your primary argument is a summary, so why should calling
> library() imply that its primary argument is a "library"?

More likely it would imply that the *result* is a library...

Anyway, it was introduced at a time where we considered it important
to be "prototype compatible" as long as there was no good reason not
to. With 20-20 hindsight, we could probably have afforded to think up
a better name.

> > It really would end this constant confusion and save various folks
> > approx 15 minutes/week in knee-jerk responses, eh?
> Afaic, one of the issues is that it seems common practice to refer to
> collections of code as "libraries" or "packages", and we're trying to
> use these rather general-purpose terms in a very precise meaning, and
> obviously not very successful, in particular because the use of
> "library" is highly non-standard.  One idea might be to replace the
> "library" by something else like ... "a place where R knows where to
> find packages" ... hmm, now that's too long, so ...

"store", or "depot" springs to mind. The latter might cause baz to go
postal, though...

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)             FAX: (+45) 35327907

More information about the R-devel mailing list